Willkommen

WipeFile
Dateien schnell und sicher löschen

WipeFile löscht Dateien und ganze Verzeichnisse schnell und sicher. Dazu überschreibt WipeFile die Dateien vor dem Löschen, um eine Wiederherstellung zu verhindern.

WipeFile kann Dateien mit 14 verschiedenen Methoden überschreiben. Dazu zählen z.B. zwei US Navy-Standards, die Standards des US Department of Defence, der US Airforce und der NATO.

Kontakt & Download

Kontakt Für Anregungen, Verbesserungs- oder Erweiterungsvorschläge schreiben Sie bitte eine E-Mail an: info@gaijin.at.
Produktseite Die neueste Version dieses Programms finden Sie auf der Produktseite von WipeFile bzw. auf www.gaijin.at.
Copyright © 2004-2020 Werner Rumpeltesz


Lizenz und Haftung

Lizenzvertrag

Lizenzvertrag für Programme zur kostenlosen privaten und kommerziellen Verwendung

Stand: 27.04.2019

Zusammenfassung

Diese Zusammenfassung gibt einen kurzen Überblick über den oben abgedruckten Lizenzvertrag, erhebt jedoch keinen Anspruch auf Vollständigkeit.

Erlaubt ist:

  • die Benutzung der Software im privaten und kommerziellen Bereich
  • die kostenlose Veröffentlichung der unveränderten Software
  • die kostenlose Weitergabe der unveränderten Software

Verboten ist:

  • der Verkauf oder die sonstige entgeltliche Weitergabe der Software
  • das Verändern der Software vor der Weitergabe
  • das Dekompilieren oder Disassemblieren der Software

Es besteht kein Recht auf:

  • Support oder sonstige Hilfestellung
  • die Behebung eines Fehlers oder auf sonstige Änderungen

Ausnahmen

Die Erteilung einer Ausnahme von den Bestimmungen dieses Lizenzvertrages erfordert eine ausdrückliche Genehmigung des Autors, die ggf. per E-Mail erteilt wird.

Kontakt Wenn Sie Fragen zur Lizenz haben, oder eine Ausnahmegenehmigung wünschen, kontaktieren Sie bitte den Autor per E-Mail unter: info@gaijin.at.

Geltungsbereich und Begriffsbestimmungen

Dieser Lizenzvertrag gilt für die Software "WipeFile" von Werner Rumpeltesz (im Folgenden "Autor" genannt).

Der Begriff "Software" in diesem Lizenzvertrag gilt für das gesamte Softwarepaket der Anwendung "WipeFile" (gesamter Inhalt des Downloadarchivs). Dies beinhaltet sowohl die ausführbare Programmdateien, als auch alle anderen Dateien, wie beispielsweise die Hilfedatei, Installationsanleitung oder Datendateien.

Allgemeines

Diese Software ist geistiges Eigentum des Autors. Das uneingeschränkte Besitzrecht an der Software bleibt beim Autor. Ihnen werden weder Eigentumsrechte noch Besitzrechte an dieser Software übertragen. Dies betrifft auch alle Kopien der Software, unabhängig der Form oder des Mediums. Neben den Rechten, die Ihnen dieser Vertrag ausdrücklich zusichert, erwerben Sie keinerlei andere Rechte an der Software.

Die Software ist nach dem österreichischen Urheberrechtsgesetz, sowie nach internationalen Verträgen, geschützt. Dem Autor oder dem Lizenznehmer gesetzlich zugesicherte Rechte oder gesetzlich auferlegte Pflichten werden durch diesen Lizenzvertrag nicht berührt. Für diesen Lizenzvertrag gilt österreichisches Recht.

Zuwiderhandlungen gegen Bestimmungen dieses Lizenzvertrages können strafrechtlich und zivilrechtlich verfolgt werden.

Rechte und Pflichten

Die Software darf kostenlos für private und kommerzielle Zwecke benutzt werden. Die Anzahl der Installationen bzw. Kopien, sowie die Anzahl der darauf zugreifenden Benutzer sind nicht limitiert.

Die Software darf kostenlos an andere Personen weitergegeben und im Internet oder auf sonstigen Medien veröffentlicht werden. Voraussetzung dafür ist, dass die Software unverändert erhalten bleibt. Ein Hinzufügen von Dateien oder ein sonstiges Verändern des Programmpaketes ist verboten. Weiters ist das Einbinden oder Nachladen der Software in oder durch andere Programme, sowie das Vorschalten anderer Programme, verboten (wie beispielsweise Installations- oder Downloadprogramme).

Die Software darf nicht verkauft, vermietet, oder sonst gegen ein Entgelt weitergegeben werden.

Sie dürfen diese Software weder zurückentwickeln (Reverse Engineering), noch deren Quellcode extrahieren (Dekompilieren oder Disassemblieren).

Es besteht kein Recht auf Support oder sonstige Hilfestellung durch den Autor.

Es besteht kein Recht auf Behebung eines Fehlers oder auf sonstige Änderungen. Insbesondere gilt dies für die Anpassung der Software auf eine bestimmte andere Software oder Hardware.

Haftungsausschluss

Die Verwendung der Software erfolgt auf eigene Verantwortung. Der Autor übernimmt keine Haftung für die Richtigkeit und Funktionsfähigkeit der Software. Der Autor haftet weder für direkte, noch für indirekte Schäden, die durch die Verwendung der Software entstehen. Dies umfasst vor allem, aber nicht ausschließlich, entgangene Gewinne oder Einnahmen, den Verlust von Daten, sonstige finanzielle Verluste oder indirekte, besondere und exemplarische Schäden sowie Folgeschäden und Schäden mit Strafschadensersatz.


Installation & Deinstallation

Installation

WipeFile muss nicht installiert werden und kann nach dem Entpacken aus dem Download-Archiv sofort gestartet werden.

Beim ersten Programmstart wird ein Konfigurationsdialog angezeigt, in dem das zu verwendende Verzeichnis für die Programmeinstellungen angegeben werden muss.

Sollen die Einstellungen für jeden Benutzer getrennt gespeichert werden, so muss die Option "Ordner für Anwendungsdaten des aktuellen Benutzers" ausgewählt werden. Die Daten werden in diesem Fall unter "%APPDATA%\WipeFile" (z.B. "C:\Dokumente und Einstellungen\Gaijin\Anwendungsdaten\WipeFile") gespeichert.

Um das Programm auf einem USB-Stick zu betreiben, müssen die Benutzereinstellungen im Programmordner von WipeFile gespeichert werden.

Anforderungen

WipeFile benötigt das Microsoft .NET Framework 4 oder höher.

Downloads:

Download Microsoft .NET Framework 4 Redistributable Package

Deinstallation

Um das Programm "WipeFile" zu entfernen, muss nur der Ordner gelöscht werden, in dem das Programm enthalten ist (s.h. "Installation").

Wurden benutzerspezifische Einstellungen verwendet, befinden sich in den unter "Installation" genannten Ordnern möglicherweise noch Einstellungsdateien.

Das Programm "WipeFile" speichert keine Einstellungen in der Windows Registrierungsdatenbank.


Programmoberfläche

Benutzeroberfläche

Hinzufügen von Ordnern und Dateien

Ordner und Dateien können in der Benutzeroberfläche über das Menü, die Werkzeugleiste, das Kontextmenü des Listenfeldes hinzugefügt werden. Es können auch Shortcuts verwendet werden, die über das Menü ersichtlich sind. Mit Befehlszeilenparameter können ebenfalls Ordner und Dateien übergeben werden. Drag & Drop vom Windows Explorer aus wird ebenso unterstützt. Eine Explorer-Integration ist in den Einstellungen aktivierbar.

Um eine oder mehrere Dateien hinzuzufügen, wählen Sie den Menüpunkt "Bearbeiten" / "Dateien hinzufügen". Um ein Verzeichnis hinzuzufügen, wählen Sie den Menüpunkt "Bearbeiten" / "Verzeichnis hinzufügen". Nach dem Hinzufügen von Verzeichnissen oder Dateien werden diese in der Verarbeitungsliste angezeigt.

Die Verarbeitungsliste

In der Spalte "Verzeichnis" wird das Verzeichnis der Datei angezeigt. In der Spalte "Dateimaske" wird der Name der Datei oder die Dateimaske angezeigt.

Bei einem Verzeichnis ist die Dateimaske "*" (Stern). Die Dateimaske kann über das Menü "Bearbeiten" / "Dateimaske bearbeiten" geändert werden. In Dateimasken können die folgenden zwei Platzhalter verwendet werden:

* (Stern)

Ein Stern steht für beliebig viele Zeichen und auch für kein Zeichen.

? (Fragezeichen)

Ein Fragezeichen steht für ein beliebiges einzelnes Zeichen.

In der Spalte "Unterordner" wird angezeigt, ob die Suche auch in Unterordnern (rekursiv) erfolgen soll. Bei Verzeichnissen ist dies standardmäßig aktiviert, bei Dateien deaktiviert. Mehr dazu unter "Verarbeitung von Dateien und Verzeichnissen". Diese Einstellung kann mit der Checkbox (dem Kontrollkästchen) an der Linken Seite, mit einem Doppelklick auf die Zeile bzw. für mehrere Zeilen über das Menü geändert werden.

Optionen

Löschmethode

Hier kann die Methode ausgewählt werden, mit der die Daten überschrieben werden sollen. Die einzelnen Löschmethoden sind unter "Löschmethoden" mit einer genauen Beschreibung angeführt. Diese Hilfeseite wird auch dann angezeigt, wenn der Eingabefokus auf dem Auswahlfeld steht und die Hilfe aufgerufen wird. Eine Beschreibung mittels Tooltip der aktuell eingestellten Löschmethode erscheint auch, wenn die Maus über dem Auswahlfeld steht.

WipeFile nach dem Überschreiben der Dateien beenden

Diese Einstellung beendet WipeFile nach dem Überschreiben der Dateien. Diese Einstellung ist identisch mit dem Befehlszeilenparameter "/Close", der auch den Anfangswert dieser Einstellung bestimmt (aktiviert oder deaktiviert).

Vorlagen

Die Pfade in der Verarbeitungsliste (Verzeichnisse, Dateien und Dateimasken), sowie die Auswahl für die rekursive Suche, können in einer Datei gespeichert und später wieder aus dieser geladen werden. Dies ist zum Beispiel dann nützlich, wenn regelmäßig die gleichen Dateien oder Verzeichnisse gelöscht werden sollen.

Die Pfade in der Verarbeitungsliste können über den Menüpunkt "Datei" / "Vorlage speichern" in eine Vorlagendatei geschrieben werden.

Vorlagen können über den Menüpunkt "Datei" / "Vorlage öffnen" geöffnet werden. Die in der Vorlage gespeicherten Pfade werden zur Verarbeitungsliste hinzugefügt. Befinden sich bereits Einträge in der Verarbeitungsliste, wird zuvor gefragt, ob die vorhandenen Einträge ersetzt werden sollen.


Einstellungen

Im Einstellungsdialog können folgende allgemeine Einstellungen vorgenommen werden:

Allgemein

Gitternetzlinien in der Verabeitungsliste anzeigen

Ist diese Option aktiviert, werden Gitternetzlinien in der Verabeitungsliste angezeigt, um die Spalten und Zeilen besser zu erkennen.

Spalten automatisch aufteilen

Die Spalten in der Verarbeitungsliste werden immer an die Fensterbreite angepasst, wenn diese Option aktiv ist.

Einträge nach dem erfolgreichen Wipen entfernen

Ist diese Option aktiviert, werden Einträge werden nach dem erfolgreichen Wipen aus der Verarbeitungsliste entfernt.

Wipe-Vorgang bestätigen

Bestimmt, ob eine Abfrage vor dem Überschreiben und Löschen der Dateien angezeigt werden soll.

Hinweismeldung nach dem Wipen anzeigen

Ist diese Option aktiviert, wird im Erfolgsfall oder bei einem Abbruch durch den Benutzer eine Hinweismeldung angezeigt.

Hinweiston nach dem Wipen abspielen

Mit dieser Einstellung kann der Hinweiston festgelegt werden, der nach dem Wipen abgespielt werden soll.

Wipen

Daten überschreiben mit Text

Beim Wipen mit den WipeFile-Methoden "Einfach", "Standard" und "Sicher" wird der angegebene Text zu Überschreiben der Daten verwendet. Wird kein Text angegeben, wird der Standard-Text verwendet.

Datei-Zeiten ändern auf

Vor dem Löschen einer Datei oder eines Verzeichnisses werden die Erstellungszeit, Änderungszeit und die letzte Zugriffszeit geändert. Diese Einstellung legt das Datum und die Zeit (in der Zeitzone UTC) fest, die den Dateien und Verzeichnissen zugewiesen werden soll. Ist die Option "Zufälliges Datum/Zeit" aktiviert, werden die Dateizeiten auf einen zufälligen Wert geändert.

Protokollierung

Umfang der Protokollierung

Mit dieser Einstellung kann der Umfang der Protokollausgabe festgelegt werden. Mögliche Optionen sind:

Keine Protokollierung

Es wird keine Protokolldatei angelegt.

Nur Fehler

Es werden nur jene Verzeichnisse und Dateien in der Protokolldatei vermerkt, bei denen Fehler aufgetreten sind. Außerdem werden allgemeine Fehler bei der Suche nach Dateien vermerkt.

Alle Dateien

Es werden alle verarbeiteten Dateien und Verzeichnisse vermerkt.

Ordner für Protokolldateien

Im Textfeld kann der Ordnerpfad für Protokolldateien angegeben werden. Mit der Schaltfläche an der rechten Seite kann ein Ordner ausgewählt werden.

Explorer-Integration

In das Kontext-Menü integrieren

Mit dieser Option kann WipeFile in das Explorer-Kontextmenü eingetragen werden.

In das "Senden an"-Menü integrieren

Mit dieser Option kann WipeFile in das "Senden An"-Menü eingetragen werden.

Verknüpfung im Startmenü jetzt erstellen

Mit dieser Schaltfläche kann eine Verknüpfung im Windows Start-Menü erstellt werden.


Allgemeine Hinweise

Der Löschvorgang

Jede Datei wird mit der eingestellten Methode ein oder mehrmals überschrieben. Anschließend wird der Dateiname auf eine zufällige Zahlen- und Buchstabenkombination (in der selben Länge wie der Originalname) geändert. Die Dateizeiten (Erstellungs-, Änderungs- und Zugriffszeit) werden auf den 01.01.2000 und die Dateilänge auf 0 Byte gesetzt. Danach wird die Datei gelöscht.

Verzeichnisse werden nur dann gelöscht, wenn sie leer sind. Ordnernamen werden vor dem Löschen ebenfalls auf einen zufälligen Wert umbenannt und die Dateizeiten wie bei Dateien geändert.

Verwendungshinweise

WipeFile überschreibt lediglich die Daten in den angegebenen Dateien selbst, nicht jedoch den File-Slack. Inhalte der überschriebenen Datei können auch noch in Auslagerungsdateien oder temporären Dateien enthalten sein, die vom Betriebssystem oder einem anderen Programm zu einem früheren Zeitpunkt dort abgelegt wurden.

Dateien aus dem Windows Papierkorb können nicht direkt gelöscht werden. Um diese Ordner/Dateien auszuwählen, müssen die Unterordner des "RECYCLER" Ordners in der jeweiligen Partition ausgewählt werden.

Verarbeitung von Dateien und Verzeichnissen

Bei der Angabe des Platzhalters "*" werden alle Dateien gelöscht. Wird als Dateimaske beispielsweise "*.txt" verwendet, werden nur die Textdateien im betreffenden Ordner gelöscht.

Hinweis: Die Dateimaske "*.*" findet nicht alle Dateien, sondern Dateien mit mindestens einem Punkt im Dateinamen. Dateien ohne Dateinamenerweitung werden mit dieser Maske nicht gefunden.

Wird ein Verzeichnis mit den Unterordnern (rekursiv) gelöscht, werden auch alle Dateien in den Unterordnern gelöscht, die auf die Dateimaske passen. Bei der Angabe des Platzhalters "*" werden alle Dateien und alle Unterverzeichnisse gelöscht.

Wird eine Datei rekursiv gelöscht, werden alle Dateien mit dem gleichen Namen auch in den Unterordnern gelöscht. Zum Beispiel werden mit dem Pfad "E:\Privat.txt" auch die Dateien "E:\Geheim\Privat.txt" und "E:\Geheim\Persönlich\Privat.txt" gelöscht.


Einstellungen

Löschmethoden

WipeFile - Einfach

Der Inhalt der Datei wird einmal mit einem festgelegten Text überschrieben.

Zero

Der Inhalt der Datei wird einmal mit 0x00 überschrieben.

Random

Der Inhalt der Datei wird einmal mit Zufallszahlen überschrieben.

WipeFile - Standard

Der Inhalt der Datei wird mit 0x00 und anschließend mit einem festgelegten Text überschrieben.

Random & Zero

Der Inhalt der Datei wird einmal mit Zufallszahlen und danach mit 0x00 überschrieben.

Zero & Random

Der Inhalt der Datei wird mit 0x00 und anschließend mit Zufallszahlen überschrieben.

Microsoft Cipher

Der Inhalt der Datei wird mit 0x00, 0x80 und 0xFF überschrieben.
Dies entspricht der Löschmethode des Konsolenbefehls "cipher /W".

US Navy - MFM

Der Inhalt der Datei wird mit 0xFF, 0xBFFFFFFF und Zufallszahlen überschrieben.
Dies entspricht der Löschmethode des Standards "NAVSO P-5239-26 - MFM" der US Navy.

US Navy - RLL

Der Inhalt der Datei wird mit 0xFF, 0x27FFFFFF und Zufallszahlen überschrieben.
Dies entspricht der Löschmethode des Standards "NAVSO P-5239-26 - RLL" der US Navy.

US DoD / US Air Force

Der Inhalt der Datei wird mit 0x00, 0xFF und Zufallszahlen überschrieben.
Dies entspricht der Löschmethode des Standards des US Department of Defense "DoD 5220.22-M" und der US Air Force "AFSSI5020".

WipeFile - Sicher

Der Inhalt der Datei wird einmal mit 0x00, danach mit 0x80, sowie mit 0xFF überschrieben. Anschließend werden die Daten mit einem festgelegten Text überschrieben.

Bit Toggle

Der Inhalt der Datei wird zweimal, jeweils mit 0x00 und 0xFF, überschrieben.

NATO Standard

Der Inhalt der Datei wird dreimal, jeweils mit 0x00 und 0xFF, überschrieben. Anschließend werden die Daten mit Zufallszahlen überschrieben.
Dies entspricht der Löschmethode des Standards der North Atlantic Treaty Organization (NATO).

Peter Gutmann

Der Inhalt der Datei wird in insgesamt 35 Schritten mit Zufallszahlen und festgelegten Werten überschrieben.


Befehlszeilenparameter

Mit Befehlszeilenparameter können WipeFile Verzeichnisse und Dateien übergeben werden, die verarbeitet werden sollen. Dateien können auch Dateimasken enthalten.

Beispiel:
WipeFile.exe "E:\Test\Löschen\" "E:\Test\Datei.txt" "E:\Test\*.dat"

In die Verarbeitungsliste wird der Ordner "E:\Test\Löschen\", die Datei "E:\Test\Datei.txt" und der Pfad mit Dateimaske "E:\Test\*.dat" eingetragen.

Vorlagen laden

Mit dem Befehlszeilenparameter "/T" (oder "/Template") kann eine oder mehrere Vorlagen beim Programmstart geladen werden. Der Dateiname wird im gleichen Parameter übergeben und mit einem Gleichzeichen (=) vom Schalter "/T" getrennt.

Beispiel:
WipeFile.exe /T="E:\Test\Template1.wft3" /T="E:\Test\Template2.wft3"

Löschmethode einstellen

Mit dem Befehlszeilenparameter "/M" (oder "/Method") kann die Löschmethode eingestellt werden. Die Kurzbezeichnung der Methode wird im gleichen Parameter übergeben und mit einem Gleichzeichen (=) vom Schalter "/M" getrennt.

Beispiel:
WipeFile.exe /M=WipeFileSecure
WipeFile.exe /Method=NAVSO_RLL
Kurzbezeichnungen:
WipeFileSimple
WipeFile - Einfach (1x)
Zero
Zero (1x)
Random
Random (1x)
WipeFileMedium
WipeFile - Mittel (2x)
RandomZero
Random & Zero (2x)
ZeroRandom
Zero & Random (2x)
MSCipher
Microsoft Cipher (3x)
NAVSO_MFM
US Navy - MFM (3x)
NAVSO_RLL
US Navy - RLL (3x)
DoD_USAF
US DoD / US Air Force (3x)
WipeFileSecure
WipeFile - Sicher (4x)
BitToggle
Bit Toggle (4x)
NATO
NATO Standard (7x)
PeterGutmann
Peter Gutmann (35x)

WipeFile automatisieren

Der Befehlszeilenparameter "/W" (oder "/Wipe") startet unmittelbar nach dem Programmstart das Überschreiben der Dateien. Diese können mit einer Vorlage oder per Befehlszeilenparameter übergeben werden.

Mit dem Befehlszeilenparameter "/S" (oder "/Silent") können alle Hinweise oder Abfragen während des Überschreibens unterdrückt werden. Dies gilt nicht für Fehlermeldungen im Zusammenhang mit der Protokollierung. Dieser Parameter wird auch dann beachtet, wenn "/W" nicht angegeben wurde, oder wenn das automatische Überschreiben auf Grund fehlender Dateien nicht gestartet wurde.

Der Befehlszeilenparameter "/C" (oder "/Close") beendet WipeFile nach dem Überschreiben der Dateien. Wird das Überschreiben durch den Benutzer abgebrochen, wird WipeFile nicht automatisch beendet.