Introduction

Altap Salamander: Plugins: Automation: Introduction

Getting Started with Automation Plugin

With the Automation plugin you can automate common tasks using scripts written in any language supported by the Windows Script Host. Windows comes with JScript and VBScript engines preinstalled, however 3rd party scripting engines are available for languages such as Perl, PHP, Python, Ruby and others.

© 2001-2019 ALTAP. All rights reserved.


What’s New in This Version

version 1.4

  • Fixed bug that caused Altap Salamander to crash when executing Python scripts
  • Some blocking operations (Form, Sleep, MsgBox etc.) can now be aborted
  • Improved plugin stability when using Ruby scripting engine

version 1.3

  • Maintenance release

version 1.2

  • Maintenance release

version 1.1

  • Button Object
  • CheckBox Object
  • Form Object
  • GetFullPath Method
  • GetPersistentVal Method
  • Label Object
  • ScriptInfo Object
  • SetPersistentVal Method
  • TextBox Object

version 1.0

  • AbortScript Method
  • AutomationVersion Property
  • DebugBreak Method
  • ErrorDialog Method
  • MatchesMask Method
  • OverwriteDialog Method
  • ProgressDialog Object
  • PathType Property
  • QuestionDialog Method
  • StoreSelection Method
  • Sleep Method
  • TraceE and TraceI Methods
  • ViewFile Method
  • WaitWindow Object
  • WindowsVersion Property


Running Your Scripts

There are two options to run your scripts. You can either save your script to the script repository or you can run arbitrary script.

Running Scripts from Repository

Automation plugin looks into the script repositories for available scripts. Such scripts are placed to the Automation plugin menu and are available from Plugins menu, from the Plugin Bar, or using Automation Open Script Menu command (Ctrl+Shift+A).

Script repositories are directories (including subdirectories) that could be set up in the configuration.

Default searched repositories are: $[AppData]\Altap\Altap Salamander\Automation\scripts, $[AllUsersProfile]\Altap\Altap Salamander\Automation\scripts, $(SalDir)\plugins\automation\scripts. $(SalDir) is full path of the Altap Salamander directory, $[ENV_VAR] is value of environment variable (replace ENV_VAR by the environment variable name).

It is possible to assign a shortcut key to the frequently used scripts in the Plugin Keyboard Shortcuts dialog box.

Running Arbitrary Script

To run arbitrary script, just focus the script file in a panel and select Run Focused Script from the Plugins or Script menu.

Aborting Script Execution

You can abort running script at any time using the Abort Script toolbar button or the Ctrl+Break keyboard shortcut.

See Also

Automation Configuration

Using Plugins


Automation Configuration

You can customize Automation plugin in this dialog. See Configuring Plugins for general information about configuration.

Options

Script Directories
Lists all the directories that should be searched for the scripts. Scripts found in these directories are added to the Automation Plugins menu and to the Script menu. Scripts placed in subdirectories are presented in submenus.
Enable script debugging
When checked, the Just-in-Time debugger installed on the system (e.g. Microsoft Script Debugger or Microsoft Visual Studio) can be attached to the script if it raises exception during the execution.


Item Object

The Item object represents a panel item.

Properties

Name | Description
Attributes | Gets file attributes of the item.
DateLastModified | Gets the date and time that the specified file was last modified.
Name | Gets item file name.
Path | Gets item full path.
Size | Gets size of the item, in bytes.

See Also

Panel Object


Items Collection

Collection of Item objects within a panel.

Properties

Name | Description
Count | Gets the number of items in a collection.
Item | Gets an item based on the specified key.

Example

VBScript

Dim TotalSize
TotalSize = 0
for each Item in Salamander.SourcePanel.Items
  TotalSize = TotalSize + Item.Size
next
Salamander.MsgBox("Total size of all items in the panel: " +
  CStr(TotalSize) + " bytes")

See Also

Item Object


Panel Object

The Panel object represents one of the Salamander's panels.

Methods

Name | Description
DeselectAll | Deselects all the items in the panel.
SelectAll | Selects all the items in the panel.
StoreSelection | Stores current selection to the selection memory.

Properties

Name | Description
FocusedItem | Gets instance of the Item object representing the focused item.
Items | Gets collection of all the items in the panel.
Path | Gets or sets panel path.
PathType | Gets type of the panel path.
SelectedItems | Gets collection of the selected items.

See Also

Item Object

Items Collection


DeselectAll Method

The DeselectAll method cancels the current selection in the panel.

Syntax

DeselectAll([save])

Parameters

save

Optional. Boolean value determining whether the current selection should be saved prior it is cancelled. By default the selection is not saved. For more information see the following Remarks section.

Return Values

This method does not return a value.

Remarks

To be consistent with other Altap Salamander operations the script should use this method to cancel the selection after it finishes the operation in the panel. Before deselecting the items the script should use the StoreSelection method to save the selection so the user is allowed to use another operation for the same files and directories. Alternatively the script can save and cancel the selection in one step by calling this method with the save parameter set to true.

See Also

Panel Object

StoreSelection Method


PathType Property

Gets type of the panel path.

Value

Constant | Description
1 | The path is MS-DOS style or UNC style disk path.
2 | The path points to an archive.
3 | The path is a file system plugin path.

See Also

Panel Object


SelectAll Method

The SelectAll method selects all the items in the panel.

Syntax

SelectAll()

Return Values

This method does not return a value.

See Also

Panel Object


StoreSelection Method

The StoreSelection method saves the current selection in the selection memory. The user can later use the Restore Selection command to reload the selection.

Syntax

StoreSelection()

Return Values

This method does not return a value.

Remarks

To be consistent with other Altap Salamander operations the script should cancel the selection with the DeselectAll method after it finishes the operation in the panel. Before deselecting the items the script should call this method to save the selection so the user is allowed to use another operation for the same files and directories.

See Also

Panel Object

DeselectAll Method


ProgressDialog Object

Represents the dialog box with progress bars.

Methods

Name | Description
AddText | Adds line of text on the progress dialog.
Hide | Hides the progress dialog.
Show | Shows the progress dialog.
Step | Advances the position by the specified increment.

Properties

Name | Description
CanCancel | Determines whether the user can cancel the progress dialog.
IsCancelled | Determines whether the user has cancelled the dialog.
Maximum | Gets or sets maximum position of the current step progress indicator.
Position | Gets or sets position of the current step progress indicator.
Style | Gets or sets style of the progress dialog.
Title | Sets or gets the dialog title.
TotalMaximum | Gets or sets maximum position of the overall progress indicator.
TotalPosition | Gets or sets position of the overall progress indicator.


AddText Method

The AddText method appends line of text to the text area of the progress dialog.

Syntax

AddText(text)

Parameters

text

Required. String to be appended to the text area.

Return Values

This method does not return a value.

See Also

ProgressDialog Object


Step Method

The Step method advances the current position by the step increment

Syntax

Step(step)

Parameters

step

The amount by which the current position should be advanced.

Return Values

This method does not return a value.

See Also

ProgressDialog Object


Style Property

The Style property determines whether the dialog is single progress bar or double progress bar dialog.

Values

Constant | Description
1 | Single progress bar dialog box.
2 | Double progress bar dialog box.

See Also

ProgressDialog Object


Salamander Forms

Contains methods for creating user interface.

Controls

Name | Description
Button | Represents push button control.
CheckBox | Represents check box control.
Control | Base class for all controls.
Form | Represents a dialog box.
Label | Represents label control.
TextBox | Represents text box control.

See Also

Salamander Object


Button Object

The Button object represents push button control.

Constructor

Name | Description
Button | Creates new instance of the Button control.

Properties

Name | Description
DialogResult | Specifies the return value from the Form.Execute method.

Inherits From

Control Object


Button Constructor

Creates new instance of the Button control.

Syntax

Button([text], [result])

Parameters

text

Optional. String displayed on the button.

result

Optional. Result of the Form.Execute method when the button is pressed. See DialogResult property of the Button control for more information.

See Also

Button Object


DialogResult Property

Specifies the return value from the Form.Execute method.

Values

Value | Description
1 | OK
2 | Cancel
3 | Abort
4 | Retry
5 | Ignore
6 | Yes
7 | No
10 | Try Again
11 | Continue

Remarks

If the DialogResult property is set to anything other than 0, clicking the button closes the parent form. The return value from the Form.Execute method will be the DialogResult of the button when the button is clicked. For example, to create a OK/Cancel dialog box, simply add two buttons and set their DialogResult properties to 1 and 2.

See Also

Button Object

Form Object


CheckBox Object

The CheckBox object represents check box control.

Constructor

Name | Description
CheckBox | Creates new instance of the CheckBox control.

Properties

Name | Description
Checked | Indicates whether the check box is in the checked state.

Remarks

Use a CheckBox to give the user an option, such as true/false or yes/no.

Inherits From

Control Object


CheckBox Constructor

Creates new instance of the CheckBox control.

Syntax

CheckBox([text])

Parameters

text

Optional. String displayed next to the check box.

See Also

CheckBox Object


Control Object

The Control object is base class for all controls.

Properties

Name | Description
Text | Gets or sets the text associated with the control.

See Also

Salamander Forms


Text Property

The Text property gets or sets the text associated with the control.

Remarks

The Text property of the control is used differently by each derived class. For example the Text property of a Form is displayed in the title bar. However, the Text property of a TextBox represents current text entered in the box.

See Also

Control Object

Form Object

TextBox Object


Form Object

The Form object represents a dialog box that makes up an application's user interface.

Constructor

Name | Description
Form | Creates new instance of the Form.

Methods

Name | Description
Execute | Executes the form as a modal dialog box.

Inherits From

Control Object

See Also

Salamander Forms


Form Constructor

Creates new instance of the Form.

Syntax

Form([title])

Parameters

title

Optional. String displayed in the title bar of the dialog box.

See Also

Form Object


Execute Method

The Execute method executes the form as a modal dialog box.

Syntax

Execute()

Return Values

Returns value of the DialogResult property of the Button that an user pressed to dismiss the dialog.

See Also

Button.DialogResult Property

Form Object


Label Object

The Label object represents label control that is typically used to provide descriptive text for a control.

Constructor

Name | Description
Label | Creates new instance of the Label control.

Inherits From

Control Object


Label Constructor

Creates new instance of the Label control.

Syntax

Label([text])

Parameters

text

Optional. String displayed on the label.

See Also

Label Object


TextBox Object

The TextBox object represents text box control that the user can use to enter text in an script.

Constructor

Name | Description
TextBox | Creates new instance of the TextBox control.

Inherits From

Control Object


TextBox Constructor

Creates new instance of the TextBox control.

Syntax

TextBox([text])

Parameters

text

Optional. Text initially displayed in the text box.

See Also

TextBox Object


Salamander Object

The Salamander object is the root object of the Altap Salamander Automation object model hierarchy. It never needs to be instantiated before invoking its properties and methods, and it is always available from any script file.

Methods

Name | Description
AbortScript | Forces script execution to stop.
DebugBreak | Breaks into the debugger.
ErrorDialog | Displays dialog box with an error message.
GetFullPath | Returns absolute canonical path for the specified path string.
GetPersistentVal | Retrieves value from the persistent storage.
InputBox | Allows the user to input a text.
MatchesMask | Matches file name against the specified file mask.
MsgBox | Displays a message in a dialog box.
OverwriteDialog | Displays file overwrite confirmation dialog box.
QuestionDialog | Displays dialog box with a question.
SetPersistentVal | Saves value accross script invocations.
Sleep | Suspends script execution for a specified length of time.
TraceE | Sends an error message to the Altap Trace Server.
TraceI | Sends an informational message to the Altap Trace Server.
ViewFile | Opens file in the associated viewer.

Properties

Name | Description
AutomationVersion | Gets the Automation plugin version number.
Forms | Contains methods for creating user interface.
LeftPanel | Gets instance of the Panel object representing the left panel.
ProgressDialog | Gets instance of the ProgressDialog object representing the progress dialog.
RightPanel | Gets instance of the Panel object representing the right panel.
Script | Retrieves the ScriptInfo object that contains information about currently running script.
SourcePanel | Gets instance of the Panel object representing the source panel.
TargetPanel | Gets instance of the Panel object representing the target panel.
Version | Gets the Altap Salamander version number.
WaitWindow | Gets instance of the WaitWindow object representing the wait window.
WindowsVersion | Gets the Windows operating system packed version number.

See Also

Panel Object

ProgressDialog Object

Salamander Forms

ScriptInfo Object

WaitWindow Object


AbortScript Method

The AbortScript method forces script execution to stop at any time.

Syntax

AbortScript()

Return Values

This method does not return a value.

See Also

Salamander Object


AutomationVersion Property

Gets the Automation plugin packed version number.

Value

Some of the possible property values are summarized in the following table.

Constant | Description
12 | Automation 1.2

See Also

Salamander Object

What’s New in This Version


DebugBreak Method

The DebugBreak method causes a breakpoint in the script, where you will be prompted to run the debugger.

Syntax

DebugBreak()

Return Values

This method does not return a value.

Remarks

If script debugging is not enabled then this method does nothing.

See Also

Automation Configuration

Salamander Object


ErrorDialog Method

The ErrorDialog method displays dialog box with an error message.

Syntax

ErrorDialog(file, error, buttons, [title])

Parameters

file

Required. File that caused the error. This can be either the File object obtained from the FileSystemObject or the Salamander panel Item or string specifying the file path.

error

Required. String containing the error description or number specifying one of the predefined system error codes.

buttons

Required. Number specifying the type of buttons to display.

Constant | Description
0 | Display OK button only.
1 | Display Retry and Cancel buttons.
2 | Display Skip, Skip All and Cancel buttons.
3 | Display Retry, Skip, Skip All and Cancel buttons.

title

Optional. String displayed in the title bar of the dialog box.

Return Values

Value | Description
1 | OK
2 | Cancel
4 | Retry
16 | Skip
17 | Skip All

See Also

Item Object

Salamander Object


GetFullPath Method

The GetFullPath returns absolute path for the specified path string.

Syntax

GetFullPath(path, [panel])

Parameters

path

Required. Absolute or relative path that should be converted to the absolute fully qualified path.

panel

Optional. Specify this parameter when path parameter is relative to source or target panel. Set it to SourcePanel for source (active) panel and TargetPanel for target (inactive) panel. When this parameter is not specified or is null, the path parameter must be absolute path.

Return Values

Returns absolute fully qualified path.

Remarks

This method uses current directories to get absolute path so path could be specified in form "c:test".

Redundant path parts such as "." and ".." will be resolved.

This method will throw exceptions when specified path is invalid.

See Also

Panel Object

Salamander Object


GetPersistentVal Method

The GetPersistentVal method retrieves value previously saved to the persistent storage with the SetPersistentVal method.

Syntax

GetPersistentVal(key)

Parameters

key

Required. String that specifies the name of the value. The string may only contain upper and lower-case A-Z, the numeric characters, 0-9, underscore, dot and colon. Length of the string is limited to 255 characters. Value names are not case sensitive.

Return Values

Returns value loaded from the persistent storage. If value with the specified name was not found, the return value is null.

See Also

Salamander Object

SetPersistentVal Method


InputBox Method

The InputBox method displays a prompt in a dialog box, waits for the user to input text or click a button, and returns a string containing the contents of the text box.

Syntax

InputBox(prompt, [title], [default])

Parameters

prompt

Required. String displayed as the message in the dialog box.

title

Optional. String displayed in the title bar of the dialog box.

default

Optional. String expression displayed in the text box as the default response if no other input is provided. If you omit default, the text box is displayed empty.

Return Values

If the user clicks OK or presses ENTER, the InputBox function returns whatever is in the text box. If the user clicks Cancel, the function returns a zero-length string ("").

See Also

Salamander Object


MatchesMask Method

The MatchesMask performs match of the file name against the specified file mask.

Syntax

MatchesMask(file, mask)

Parameters

file

Required. String specifying the name of the file the match should be performed on.

mask

Required. String specifying the file mask the match should be performed against.

Return Values

If the file name matches the specified mask the return value is true. Otherwise the return value is false.

See Also

File Masks

Salamander Object


MsgBox Method

The MsgBox method displays a message in a dialog box.

Syntax

MsgBox(prompt, [buttons], [title])

Parameters

prompt

Required. String displayed as the message in the dialog box.

buttons

Optional. Numeric expression that is the sum of values specifying the number and type of buttons to display, the icon style to use and the identity of the default button. If omitted, the default value for buttons is 0.

Constant | Description
0 | Display OK button only.
1 | Display OK and Cancel buttons.
2 | Display Abort, Retry and Ignore buttons.
3 | Display Yes, No and Cancel buttons.
4 | Display Yes and No buttons.
5 | Display Retry and Cancel buttons.
6 | Display Cancel, Try Again and Continue buttons.
7 | Display Continue and Abort buttons.
16 | Display error message icon.
32 | Display query message icon.
48 | Display warning message icon.
64 | Display information message icon.
0 | First button is default.
256 | Second button is default.
512 | Third button is default.
768 | Fourth button is default.

title

Optional. String displayed in the title bar of the dialog box.

Return Values

Value | Description
1 | OK
2 | Cancel
3 | Abort
4 | Retry
5 | Ignore
6 | Yes
7 | No
10 | Try Again
11 | Continue

See Also

Salamander Object


OverwriteDialog Method

The OverwriteDialog method displays file overwrite confirmation dialog box.

Syntax

OverwriteDialog(file1, file2, buttons)

Parameters

file1

Required. File that is supposed to be overwritten with the second file. For more information see the following Remarks section.

file2

Required. File that is supposed to overwrite the first file. For more information see the following Remarks section.

buttons

Required. Number specifying the type of buttons to display.

Constant | Description
4 | Display Yes, All, Skip, Skip All and Cancel buttons.
5 | Display Yes, No and Cancel buttons.

Return Values

Value | Description
2 | Cancel
6 | Yes
7 | No
16 | Skip
17 | Skip All
18 | All

Remarks

The file parameters can be either the File objects obtained from the FileSystemObject or the Salamander panel Item objects. If you can retrieve neither of these object types you can use multiline string in place of these parameters. The first line of the text should specify the full file path. The second line should specify additional information like file size and date and time when the file was last modified. The lines of text should be separated with the new line (CR) character.

See Also

Item Object

Salamander Object


QuestionDialog Method

The QuestionDialog method displays dialog box with a question.

Syntax

QuestionDialog(file, question, buttons, [title])

Parameters

file

Required. File that is subject of the question. This can be either the File object obtained from the FileSystemObject or the Salamander panel Item or string specifying the file path.

question

Required. String specifying the question.

buttons

Required. Number specifying the type of buttons to display.

Constant | Description
4 | Display Yes, All, Skip, Skip All and Cancel buttons.
5 | Display Yes, No and Cancel buttons.
6 | Display Yes, All and Cancel buttons.

title

Optional. String displayed in the title bar of the dialog box.

Return Values

Value | Description
2 | Cancel
6 | Yes
7 | No
16 | Skip
17 | Skip All
18 | All

See Also

Item Object

Salamander Object


SetPersistentVal Method

The SetPersistentVal method saves value to the persistent storage. The value is then available next time the script is invoked and it is also accessible from different scripts.

Syntax

SetPersistentVal(key, val)

Parameters

key

Required. String that specifies the name of the value. The string may only contain upper and lower-case A–Z, the numeric characters, 0–9, underscore, dot and colon. Length of the string is limited to 255 characters. Value names are not case sensitive.

val

Value to be saved. Only string and integer data types are supported. To delete a value set it to null.

Remarks

Since the persistent values are shared among all the scripts you should ensure to use unique name for private values. Otherwise the name can clash with another script’s private value. By convention the private name is formed according to the scheme [script_name][dot][value_name].

To retrieve saved value the script uses the GetPersistentVal method.

Example

JScript

// set public value
Salamander.SetPersistentVal("PublicValueName", 6);

// set private value
Salamander.SetPersistentVal("ScriptName.PrivateValueName", "hello");

// delete the value
Salamander.SetPersistentVal("ValueToDelete", null);

See Also

GetPersistentVal Method

Salamander Object


Sleep Method

The Sleep method suspends script execution for a specified length of time, then continues execution.

Syntax

Sleep(time)

Parameters

time

Required. Integer value indicating the interval (in milliseconds) you want the script process to be inactive.

Return Values

This method does not return a value.

See Also

Salamander Object


Trace Methods

Altap Salamander: Plugins: Automation: Reference: Salamander Object

TraceE, TraceI Methods

These methods send a message to the Altap Trace Server. The TraceE method sends the error level message, while the TraceI method sends the information level message.

Syntax

TraceE(message)
TraceI(message)

Parameters

message

Required. String to be sent to the Trace Server.

Return Values

These methods do not return a value.

Remarks

The Altap Trace Server is the debugging tool available as a part of Preview Build Altap Salamander installations or as a part of the Altap Salamander Plugin SDK. In release versions of the Altap Salamander these methods do nothing.

See Also

Salamander Object


ViewFile Method

The ViewFile method opens the specified file in the associated viewer.

Syntax

ViewFile(file, [cache])

Parameters

file

Required. The name of the file.

cache

Optional. Specifies whether the disk cache should be used when viewing the file. This can be one of the following values:

Constant | Description
0 | The disk cache will not be used. This is the default behavior.
1 | The file will be copied to the disk cache before it is opened in the viewer. The caller can safely delete the file immediately after the method returns.
2 | The file will be moved to the disk cache before it is opened in the viewer. The file will be automatically deleted from the cache once the user closes the viewer window.

Return Values

This method does not return a value.

See Also

Salamander Object


WindowsVersion Property

Gets the Windows operating system packed version number.

Value

Some of the possible property values are summarized in the following table.

Constant | Description
50 | Windows 2000
51 | Windows XP
60 | Windows Vista
61 | Windows 7

See Also

Salamander Object


ScriptInfo Object

The ScriptInfo object contains information about the currently running script.

Properties

Name | Description
Name | Gets name of the currently running script.
Path | Gets full file path to the currently running script.

See Also

Script Property


WaitWindow Object

The WaitWindow object represents the wait window. Wait windows are used to inform users about lengthy operations when progress of the operation cannot be determined. The ProgressDialog object provides better alternative to inform users about progress of a lengthy operation.

Methods

Name | Description
Hide | Hides the wait window.
Show | Shows the wait window.

Properties

Name | Description
CanCancel | Determines whether the user can cancel the progress dialog.
Delay | Gets or sets initial delay before the wait window is displayed.
IsCancelled | Determines whether the user has cancelled the dialog.
Text | Sets or gets the text displayed inside the wait window.
Title | Sets or gets the wait window title.

See Also

ProgressDialog Object


Sample Scripts

This page provides information on working with the samples that are included with the Automation Plugin.

Convert Images

Converts selected images (and images in selected directories) using open source ImageMagick tools. This script can be easily adapted for other, typically conversion, operations with files. Features: recursive directory walking, file masks matching, calling external application (ImageMagick convert command), progress dialog box, overwrite dialog box with Yes, All, Skip, Skip All and Cancel buttons, error states handling, output log with opearation summary. Requires: ImageMagick (either x86 or x64).

Count Lines

Counts lines of selected files (and files in selected directories). Features: recursive directory walking, file masks matching, progress dialog box, error states handling with Retry, Skip, Skip All, and Cancel error dialog box, regular expressions, output log with opearation summary.

Launch Elevated Command Prompt

You can use this script on Windows Vista or later to launch elevated command prompt from the source directory. On Windows XP this script can launch the command prompt as a different user. This script demonstrates creating and using external automation objects.

Make Link

This script creates a symbolic link to the file or the directory focused in the source panel. This script demonstrates use of the InputBox method. Windows Vista or later is required to run the script.

Make List

This script performs similar function as the Make File List command built into the Altap Salamander. It creates list of the items in the source panel, saves it in the CSV format and opens it in the associated application. The script demonstrates use of the MsgBox method and iterating through the items collection.

Unpack Multiple Archives

Unpack selected archives (and archives in selected directories) using open source 7-Zip archiver. This script can be easily adapted for other unpackers. Features: recursive directory walking, file masks matching, calling external application (7-Zip archiver), error states handling, output log with opearation summary. Requires: 7-Zip (either x86 or x64).


Scripting Engines

JScript

JScript engine comes preinstalled by default on Microsoft Windows. The file extension is .js.

Perl

ActivePerl scripting engine is available from ActiveState.

PHP

PHP active script extension is part of the PECL package. The last available version is 5.2.6. The extension seems to be no longer maintained and is quite buggy. After you install the extension as described in manual you will have to add following entries into the registry to associate the .phps extension with the PHP scripting engine.

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.phps]
@="PHPScriptFile"

[HKEY_CLASSES_ROOT\PHPScriptFile]
@="PHP Script File"

[HKEY_CLASSES_ROOT\PHPScriptFile\ScriptEngine]
@="PHPScript"

Python

ActivePython scripting engine is available from ActiveState. The file extension should be .pys.

Ruby

ActiveScriptRuby implements scripting engine for the Ruby language.

VBScript

Visual Basic scripting engine is installed by default in Microsoft Windows. The file extension is .vbs.


CanCancel Property

The CanCancel method determines whether the user can cancel the progress dialog.

See Also

ProgressDialog Object