Benvenuto in RegAlyzer

RegAlyzer
Freeware, © 2000-2004 Patrick Michael Kolla / Safer Networking Limited

RegAlyzer è uno strumento di consultazione e di elaborazione del registro. Include alcune caratteristiche non presenti nel Regedit originale fornito da Microsoft. Tali caratteristiche sono:

  • Funzione di ricerca migliorata. RegAlyzer consente di scorrere i risultati mentre la ricerca è ancora in esecuzione e di esportarli in un file reg. Inoltre si possono effettuare ricerche booleane e con caratteri jolly.
  • Supporto di segnalibri con struttura gerarchica. Con RegAlyzer si possono ordinare per cartelle i propri segnalibri.
  • Posizionamenti. Utilizzando parametri a riga di comando o incollando l'indirizzo nell'omonimo campo, è possibile andare direttamente ad un indirizzo specifico.
  • Elaborazione di valori binari DWord. RegAlyzer visualizza (e consente di elaborare) i DWord in formato decimale, esadecimale e binario.
  • Supporto dei valori QWords. Il Regedit originale è in grado di elaborare questi numeri interi a 64-bit, ma non di aggiungerne di nuovi.
  • Visualizzazione di file reg. RegAlyzer può visualizzare in strutture ad albero il contenuto dei file reg, senza la necessità di doverli prima importare.
  • Supporto Unicode in Windows 9x, seppure limitato. RegAlyzer può leggere i file reg versione 5 anche in Windows 9x.
  • Visualizzazione delle impostazioni di sicurezza a basso-livello. Le impostazioni di sicurezza per le chiavi (solo su Windows NT, 2000 e XP) vengono visualizzate in una struttura più basilare di quella del gestore delle autorizzazioni di Regedit.

Ancora qualche funzionalità manca, ma verranno aggiunte con le prossime versioni.


Finestra principale

La finestra principale è stata creata in modo simile a quella del Regedit originale per renderne semplice l'utilizzo, ma con alcune aggiunte:

  • Comprende una barra degli indirizzi che può essere utilizzata sia come cronologia (seleziona le chiavi precedentemente visualizzate) che per digitare o incollare indirizzi che si desiderano raggiungere.
  • Una scheda Informazioni di Sicurezza per visualizzare i diritti di accesso alla chiave selezionata (disponibile solo in Windows NT, 2000 e XP).
  • Nuove sono anche le Info database, in grado di contenere le informazioni relative alla chiave e/o al valore correntemente selezionato, tratte da un database personalizzato o precompilato. Queste possono essere elaborate nel momento in cui si iniziano a digitare nuovi testi: apparirà un pulsante Salva.
    Una futura versione di RegAlyzer comprenderà un browser di database che consentirà di consultare l'elenco delle informazioni disponibili.
  • Il menù Segnalibri costituisce una versione estesa del menù Preferiti di Regedit, per consentire la visualizzazione in una struttura gerarchica.
  • Il menù Lingue consente di selezionare lingue diverse.

Scorciatoie da tastiera

Ci sono diverse scorciatoie da tastiera che possono essere impiegate per velocizzare l'uso. E' possibile navigare nella finestra di visualizzazione struttura delle chiavi come in qualsiasi altra, ma in più:

  • Ins inserisce una nuova chiave.
  • Canc elimina la chiave correntemente selezionata.
  • F2 consente di rinominare una chiave.
  • F5 aggiorna la visualizzazione.
  • Ctrl+B aggiunge ai segnalibri la chiave corrente.

Scorciatoie simili sono disponibili anche per l'elenco dei valori nella parte destra della finestra:

  • Ins apre il menù contestuale che consente di inserire nuovi valori.
  • Canc elimina il valore correntemente selezionato.
  • Invio apre la finestra di dialogo per l'elaborazione dei dati.
  • F2 consente di rinominare un valore.
  • F5 aggiorna la visualizzazione.

In aggiunta a queste ci sono altre scorciatoie estese a tutta la finestra principale:

  • Ctrl+F apre la scheda di ricerca.
  • Ctrl+J consente di inserire un indirizzo da aprire.
  • Ctrl+M apre il gestore dei segnalibri.
  • Ctrl+O consente di aprire un file reg esterno.


Segnalibri

La gestione dei segnalibri è piuttosto semplice da utilizzare. Per posizionarsi su una chiave di registro presente nei segnalibri, è sufficiente selezionarla dal menù Segnalibri.

Se desideri aggiungere ai segnalibri una chiave specifica, effettua un clic destro su di essa nella visualizzazione struttura della finestra principale e seleziona Aggiungi ai segnalibri.... Ti verrà chiesto di inserire un nome per il nuovo segnalibro che in tal modo verrà aggiunto.

Per gestire i segnalibri, premi Ctrl+B oppure seleziona Gestisci segnalibri dal menù Segnalibri. Apparirà una nuova finestra che mostra la loro struttura. Da qui è possibile spostare i segnalibri tra le varie cartelle (semplicemente trascinandoli sulla nuova cartella) e creare, rinominare ed eliminare cartelle e segnalibri. Se commetti qualche errore, utilizza semplicemente il pulsante Annulla per tornare alla situazione esistente prima delle modifiche.


Ricerca

Premendo Ctrl+F o selezionando Cerca... dal menù Modifica, è possibile aprire la scheda di ricerca. Questa presenta una vasta gamma di opzioni, descritte qui di seguito.

Criteri di ricerca - è la scheda che viene visualizzata quando la finestra di dialogo della ricerca viene aperta. Per prima cosa bisogna selezionare lo stile di ricerca. Vi sono tre possibilità:

  • Ricerca semplice delle sottostringhe: serve semplicemente a cercare se un dato testo appare o meno da qualche parte.
  • Ricerca con caratteri jolly: i caratteri jolly sono i segni * e ?; potresti già averli provati con le ricerche di file. Il ? rappresenta un segnaposto singolo che può sostituire un carattere qualsiasi. L'* sostituisce un numero qualsiasi di caratteri.
    Esempio: "Numero ?" troverà qualsiasi testo i cui primi 7 caratteri sono "Numero " più un ottavo carattere (che può assumere qualsiasi valore). "Numero *" troverà qualsiasi testo in cui i primi 7 caratteri sono ancora "Numero ", ma seguiti da niente o da un numero qualsiasi di caratteri ulteriori.
  • Ricerca booleana: possono essere utilizzate le parole chiave AND, OR e NOT per creare regole di ricerca.
    Esempio: "Windows AND Temp" individuerà soltanto le stringhe di testo che conterranno entrambi le parole ("Windows" e "Temp"), mentre "Windows OR Temp" troverà le stringhe che contengono una delle parole (o entrambi).

Poi viene il campo Ricerca di in cui va inserito il testo da cercare. Le regole dello Stile ricerca vengono applicate qui.

In Obiettivi ricerca, è possibile indicare se ricercare solo nelle chiavi di registro, nei valori, nei dati o in una qualsiasi combinazione di essi.

In Tipi di dati, si può limitare la ricerca a specifiche tipologie di dati; ad esempio solo valori numerici o solo testo.

L'ambito di ricerca determina se effettuare la ricerca in tutto il registro oppure solo nella chiave correntemente selezionata nella finestra principale.

Le opzioni varie sono due: Ignora M/m che non terrà conto di maiuscole e minuscole nei termini di ricerca (se si digita "Windows", anche "windows" verrà individuato); la Ricerca veloce inibisce ogni modifica all'interfaccia utente durante la scansione in modo da velocizzarla e dovrebbe essere utilizzata solo se non si è interessati a vedere i risultati durante la scansione.

La scheda successiva, denominata ... per data, è applicabile soltanto ai sistemi operativi Windows NT, 2000 e XP. Se si utilizza uno di questi, è possibile limitare la ricerca per data; ad esempio si può scegliere di cercare solo voci anteriori ad una data specifica, o posteriori, oppure comprese o esterne ad un intervallo di due date.

Infine, dopo aver premuto il pulsante Cerca i risultati inizieranno a fluire; questi saranno mostrati nella scheda Risultati. Se viene effettuato un doppio clic su una voce qui contenuta, la finestra principale visualizzerà quella posizione. Se si vogliono esportare i risultati, è sufficiente spuntare le caselle di controllo davanti alle voci desiderate. Poi si dovrà effettuare un clic destro sull'elenco per visualizzare un menù contestuale che consentirà di esportare in file reg i risultati selezionati.

Al termine della ricerca apparirà una nuova scheda Sostituisci. Qui è possibile inserire una specifica stringa di testo per sostituirne un'altra, e selezionare se ignorare le maiuscole/minuscole e se sovrascrivere altre chiavi o valori, nel caso in cui la ridenominazione provocasse un conflitto di nome. Il pulsante Sostituisci rimpiazzerà soltanto le voci selezionate nell'elenco dei Risultati, e solo i nomi delle chiavi, dei valori e dei dati stringa (nelle tre varianti). I valori numerici seguiranno successivamente.